天道财富网-中国最全面的2017注册送白菜学习交流平台!

推荐文章-注册送白菜网站

操盘手指标公式

通达信MACD资金趋势指标-注册送白菜网站

A:=VOL*C;
B:=SUM(A,1)/SUM(VOL,1);
B1:=EMA(B,17);
资金:=(B-B1)*100/B;
DIFF:EMA(资金,12)-EMA(资金,26);
DEA: EMA(DIFF,9);
M:2*(DIFF-DEA), COLORSTICK;
{红色立柱}
STICKLINE(M>=REF(M,1)AND M>0,0,M,2.2,0),COLOR000088;
STICKLINE(M>=REF(M,1)AND M>0,0,M,1.5,0),COLOR0000AA;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.5,0),COLOR0000CC;
STICKLINE(M>=REF(M,1)AND M>0,0,M,0.1,0),COLOR0000EE;
{金黄色立柱}
STICKLINE(M<REF(M,1)AND M>0,0,M,2.2,0),COLOR338888;
STICKLINE(M<REF(M,1)AND M>0,0,M,1.3,0),COLOR33AAAA;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.9,0),COLOR33CCCC;
STICKLINE(M<REF(M,1)AND M>0,0,M,0.1,0),COLOR33EEEE;
{粉红立柱}
STICKLINE(M>REF(M,1)AND M<0,0,M,2.2,0),COLORCC00CC;
STICKLINE(M>REF(M,1)AND M<0,0,M,1.1,0),COLOREE00EE;
STICKLINE(M>REF(M,1)AND M<0,0,M,0.1,0)COLORFF00FF;
{绿色立柱}
STICKLINE(M<=REF(M,1)AND M<0,0,M,2.2,0),COLOR009900;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.5,0),COLOR00BB00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,1.1,0),COLOR00DD00;
STICKLINE(M<=REF(M,1)AND M<0,0,M,0.1,0),COLOR00FF00;
IF(DIFF<0,DIFF,0),COLORRED,LINETHICK2;
IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK2;
IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK2;
IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;
金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
{金黄色立柱}
DRAWICON(低金叉,-3, 1);
DRAWTEXT(低金叉,-3.6,' 金叉'),COLORYELLOW;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二金:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二金,DEA*2.4,1) ;
DRAWTEXT(二金,DEA*2.6,' 二次金叉'),COLORFFFFFF;
天道财富网:{WWW.028178.COM}INDEXADV,COLOR0000EE,NODRAW;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1)AND CROSS(DIFF,DEA);
DRAWLINE(A1=0,DEA,底背,DEA,0),COLORRED,LINETHICK2;
DRAWICON(底背,4, 2);
DRAWTEXT(底背,4.6,'底背离'),COLOR00FF00;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
DRAWLINE(A2=0,DEA,顶背,DEA,0),COLORFFFF00,LINETHICK2;
DRAWICON(顶背,4, 2);
DRAWTEXT(顶背,4.6,' 顶背离'),COLORFFFF00;
TAG: macd趋势