天道财富网-中国最全面的2017注册送白菜学习交流平台!

通达信指标公式

通达信突破三角形顶主图及选股指标公式-注册送白菜网站

N:=3;
A1:=REF(H,N)=HHV(H,2*N+1); 
B1:=FILTER(A1,N); 
C1:=BACKSET(B1,N+1); 
D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1); 
B2:=FILTER(A2,N); 
C2:=BACKSET(B2,N+1); 
D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; 
E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); 
H2:=D1 AND NOT(D2 AND E1>=E2);X1:=REF(BARSLAST(H1),1)+1; 
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); 
LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; 
WF2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=WF2>REF(WF2,1); 
WI2:=BACKSET(G2,2); 
HD:=WI2>REF(WI2,1),LINETHICK0;{过滤后高点}
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); 
S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); 
U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); 
S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); 
U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); 
U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); 
U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); 
S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); 
S4:=R4>REF(R4,1); {前四高}
★压力1:DRAWLINE(S2,H,S1,H,1),COLORMAGENTA,LINETHICK1;
★支撑1:DRAWLINE(U2,L,U1,L,1),COLOR8FBC8F,LINETHICK1;
★压力2:DRAWLINE(S3,H,S2,H,1),COLORFF8000; 
★支撑2:DRAWLINE(U3,L,U2,L,1),COLOR99CC32; 
★压力3:DRAWLINE(S4,H,S3,H,1),COLOR0000FF;
★支撑3:DRAWLINE(U4,L,U3,L,1),COLOR00FF7F;
DRAWICON(S2,H*1.01,10);
DRAWICON(S3,H*1.01,10);
DRAWNUMBER(S2,H*1.02,H),COLORCFB53B;
DRAWNUMBER(S1,H*1.02,H),COLORCFB53B;
DRAWNUMBER(S3,H*1.02,H),COLORCFB53B;
DRAWICON(U1,L*0.99,11); 
DRAWICON(U2,L*0.99,11);
DRAWICON(U3,L*0.99,11);
DRAWICON(U4,L*0.99,11);
DRAWNUMBER(U1,L*0.98,L),COLORCYAN;
DRAWNUMBER(U2,L*0.98,L),COLORCYAN;
DRAWNUMBER(U3,L*0.98,L),COLORCYAN;
DRAWNUMBER(U4,L*0.98,L),COLORCYAN;
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3); 
C10304:=BACKSET(B10304,3+1); 
D10304:=FILTER(C10304,3);{高点}
A20304:=REF(LOW,3)=LLV(LOW,2*3+1); 
B20304:=FILTER(A20304,3); 
C20304:=BACKSET(B20304,3+1); 
D20304:=FILTER(C20304,3);{低点}
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; 
E20304:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
H20304:=D10304 AND NOT(D20304 AND E10304>=E20304);
L10304:=D20304 AND NOT(D10304 AND E10304=E20304);
X10304:=REF(BARSLAST(H10304),1)+1; 
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1); 
I10304:=BACKSET(G10304,2);
LD0304:=I10304>REF(I10304,1);{过滤后低点}
L20304:=LD0304 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1; 
F2:=BACKSET(L20304 AND COUNT(H20304,X20304)>0,HHVBARS(IF(H20304,HIGH,0),X20304));
G20304:=F2>REF(F2,1); 
I2:=BACKSET(G20304,2); 
HD0304:=I2>REF(I2,1);{过滤后高点}
J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD0304),BARSLAST(LD0304))+1); 
J2:=J1>REF(J1,1);
A3:=H; 
B3:=REF(H,REF(BARSLAST(HD0304),1)+1)>REF(H,REF(BARSLAST(HD0304),1)+2+REF(BARSLAST(HD0304),REF(BARSLAST(HD0304),1)+2));
D3:=A3 AND B3 AND HD0304; 
E3:=BACKSET(D3,REF(BARSLAST(HD0304),1)+2); 
HH:=E3>REF(E3,1);{找出全部长期高点}
A4:=L>REF(L,REF(BARSLAST(LD0304),1)+1);
B4:=REF(L,REF(BARSLAST(LD0304),1)+1); 
D4:=A4 AND B4 AND LD0304; E4:=BACKSET(D4,REF(BARSLAST(LD0304),1)+2); 
LL:=E4>REF(E4,1);{找出全部长期低点}
H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线}
X3:=REF(BARSLAST(H3),1)+1; F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
G3:=F3>REF(F3,1); I3:=BACKSET(G3,2); LZ:=I3>REF(I3,1); {长期低点,也可供引用}
L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;
X4:=REF(BARSLAST(L4),1)+1; F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用}
K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
UU:=BACKSET(ISLASTBAR,BARSLAST(LD0304)+1);VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD0304),1)+2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(ISLASTBAR,BARSLAST(HD0304)+1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD0304),1)+2);
XX20304:=WW2>REF(WW2,1);
{以下语句为三角形部分}
底:=REF(L,BARSLAST(VV)),COLORRED,LINETHICK2; 
頂:=REF(H,BARSLAST(VV2)),COLORGREEN,LINETHICK2;
{以下语句为三角形部分}
顶线:REF(H,BARSLAST(VV2)),COLORGREEN,LINETHICK1;
底线:REF(L,BARSLAST(VV)),COLORRED,LINETHICK1; 
STICKLINE(VV,頂,底,0,0),COLORGREEN,LINETHICK3;
DRAWLINE(VV2,H,VV,L,0),COLORGREEN,LINETHICK3;
DRAWLINE(VV2,H,VV,頂,0),COLORGREEN,LINETHICK3;
STICKLINE(VV2 ,頂,底,0,0),COLORRED,LINETHICK3;
DRAWLINE(VV,L,VV2,H,0),COLORRED,LINETHICK3;
DRAWLINE(VV,L,VV2,底,0),COLORRED,LINETHICK3;
{
选股公式:
A10304:=REF(HIGH,3)=HHV(HIGH,2*3+1);
B10304:=FILTER(A10304,3); 
C10304:=BACKSET(B10304,3+1); 
D10304:=FILTER(C10304,3);
A20304:=REF(LOW,3)=LLV(LOW,2*3+1); 
B20304:=FILTER(A20304,3); 
C20304:=BACKSET(B20304,3+1); 
D20304:=FILTER(C20304,3);
E10304:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; 
E20304:=(HIGH+LOW)/2;
H10304:=(D10304 AND NOT(D20304 AND E10304>=E20304)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
H20304:=D10304 AND NOT(D20304 AND E10304>=E20304);
L10304:=D20304 AND NOT(D10304 AND E10304=E20304);
X10304:=REF(BARSLAST(H10304),1)+1; 
F10304:=BACKSET(H10304 AND COUNT(L10304,X10304)>0,LLVBARS(IF(L10304,LOW,10000),X10304));
G10304:=F10304>REF(F10304,1); 
I10304:=BACKSET(G10304,2);
LD0304:=I10304>REF(I10304,1);
L20304:=LD0304 OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X20304:=REF(BARSLAST(L20304),1)+1; 
F2:=BACKSET(L20304 AND COUNT(H20304,X20304)>0,HHVBARS(IF(H20304,HIGH,0),X20304));
G20304:=F2>REF(F2,1); 
I2:=BACKSET(G20304,2); 
HD0304:=I2>REF(I2,1);
UU:=BACKSET(ISLASTBAR,BARSLAST(LD0304)+1);
VV:=UU>REF(UU,1);
UU2:=BACKSET(ISLASTBAR,BARSLAST(HD0304)+1);
VV2:=UU2>REF(UU2,1);
顶:=REF(H,BARSLAST(VV2));
ST:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
停牌:=DYNAINFO(4)>0;
QST:=ST AND 停牌;
突破顶:REF(C,1)<顶 AND C>顶 AND QST;
}

 阅读这篇文章的人还阅读了:


TAG: 通达信